万事、塞翁が馬

人生の幸・不幸は予測しがたい。京都の酒造ベンチャー"FLFS"の「名目上の社長」こと姉崎亮太の平凡な日常の記録。

RaspberryPiではブラザーのプリンタは動かないらしい。

ラズパイをプリンタサーバにしようと思って買ったもののプリンタのインストールが上手くいかない。

cannonのインクジェット ip2700とブラザーのレーザプリンタ3170cdwを使い分けて使用したいのだが、ip2700はすんなりインストールできたがブラザーが全くダメ。困って色々と調べたんだが、どうやら

インテルi386のcpuを使ってるPCのLinux用のドライバは出てるが、ラズパイのARM用のドライバはない」

という事のようだ。

インストールしようとしても「このファイルはi386用だから動かないぜ」と表示される。まったく困ったものだ。

i386用のドライバで使えないかと調べてみたらできないわけでもないらしい。

raspberrypie.blog.jp

 

ただこのブログの記事に説明がまったくないのでどういう理屈かわからず。とりあえず保留だ。今後はプリンタを買いなおすときにはラズパイで行けるかをチェックする。